SwiftMQ HA Router CLI issue - Cannot connect using the HA jndi url

classic Classic list List threaded Threaded
2 messages Options
WMR
Reply | Threaded
Open this post in threaded view
|

SwiftMQ HA Router CLI issue - Cannot connect using the HA jndi url

WMR
This post was updated on .
When I started the CLI with the below JNDI url it gives me an error. The JNDI name was taken from the ha_next_tasks.txt and the same url works fine with the SwiftMQ explorer.

java -cp ../../jars/swiftmq.jar:../../jars/jline.jar:../../jars/jndi.jar:../../jars/jms.jar:../../jars/dom4j-full.jar:../../jars/xstream.jar com.swiftmq.admin.cli.CLI smqp://localhost:4001/host2=localhost;port2=4002;timeout=10000;reconnect=true;retrydelay=1000;maxretries=50;debug=true plainsocket@router1

bash-4.1$ ./cli

usage: java com.swiftmq.admin.cli.CLI <smqp-url> <qcf> [<scriptfile>]

<smqp-url>   is the JNDI-Provider-URL like 'smqp://localhost:4001/timeout=10000'
<qcf>        is the name of the queue connection factory
             like 'QueueConnectionFactory'
<scriptfile> name of an optional file with CLI commands

See SwiftMQ's documentation for details



Any idea why this error is thrown? This works fine If i configure the JNDI as 'smqp://localhost:4001/timeout=10000' . . but the HA jndi is not working here.

used version: swiftmq_ha_9_7_1_eval
Reply | Threaded
Open this post in threaded view
|

Re: SwiftMQ HA Router CLI issue - Cannot connect using the HA jndi url

IIT Software
Administrator
I guess it's a shell problem because ; separates shell commands. Put the URL in apostrophs and it should work.