Running Swiftmq on serverjre ?

classic Classic list List threaded Threaded
4 messages Options
jon
Reply | Threaded
Open this post in threaded view
|

Running Swiftmq on serverjre ?

jon
Hi We are currently using Swift 9.3.1 and would be upgrading to 10.x  

I try to run the swift with serverJRE and it seems works ok.
http://www.oracle.com/technetwork/java/javase/downloads/server-jre8-downloads-2133154.html

However I just want to have confirmation whether anyone have any problem running swift using serverJRE in production ?  

Is there any limitation or gotcha?  


Thanks in advance.  

Joni
Reply | Threaded
Open this post in threaded view
|

Re: Running Swiftmq on serverjre ?

IIT Software
Administrator
The server JVM is actually default for SwiftMQ. If you look into the smqr1 script, you‘ll see:

java -server ...

So the server JVM is launched anytime.
jon
Reply | Threaded
Open this post in threaded view
|

Re: Running Swiftmq on serverjre ?

jon
This post was updated on .
Thanks for the reply,

The usual JRE/JDK includes java plugins, etc.  While the server JRE does not include that.... but I am not sure whether the exclusion of these plugins would affect swift ?  


Can you let me know?  Because your answer is not clear to me, if you use
java -server  could be invoked in any JRE flavor.  I am particularly asking about the  server JRE that released separately from JDK/JRE.
Reply | Threaded
Open this post in threaded view
|

Re: Running Swiftmq on serverjre ?

IIT Software
Administrator
Yes, that works. Java plugins are for browsers and are not required.